下面小编就为大家带来一篇浅谈前端制作中,IE6还有必要兼容吗?小编觉得挺不错的,现在分享给大家,也给大家做个参考。一起跟随小编过来看看吧

国内市场对IE 6~7支持还有一定需求,但对于一个前端开发者,我们应该去推动这个行业向前发展,而不是一味迁就、妥协。

曾经,能够提供支持老版本 IE 是一个前端开发者的必备技能。随着移动互联网大潮来临,这个技能不再那么重要。

对于有多年前端开发经验的开发者,支持IE 6~7应该不在话下,但应该靠自己的经验和影响力,引领那些新入行的开发者关注、使用前沿的技术,而不是因循守旧。对于新入行的开发者,我们建议直接忽略老的IE浏览器,在老的浏览器上浪费时间、精力对你的职业生涯毫无裨益。这些浏览器很快就会被放进博物馆,你现在学习的针对这些旧浏览器的知识将变得一文不值。当然,如果有人致力成为浏览器考古专家,那另当别论。

我们曾天真的期望国内的互联网巨头能像Google一样,放弃对老版本IE的支持,依靠他们庞大的用户量和影响力,引领用户使用体验更好的浏览器。显然,是我们想多了。商业利益何其重要,节操何其稀少,正如微软停止XP技术支持,有人迅速来插一脚一样。

作为这个行业从业者,我们应该尝试说服客户,说服主管,不要在旧浏览器上浪费人力物力。如果无法改变他们,可以改变自己,越来越多公司只针对现代浏览器开发。把搞兼容老版浏览器的时间拿来享受生活,陪陪家人、陪陪妹子,多好。什么?你东西南北漂,家太远;也没有妹子?那你还不赶快去找妹子!天天搞古董浏览器,注定孤独到老。

我们无意批评老版IE,只是说她已经完成她的使命,到了寿终正寝的时候了。

以上这篇浅谈前端制作中,IE6还有必要兼容吗就是小编分享给大家的全部内容了,希望能给大家一个参考,也希望大家多多支持摩客站。

点赞(7869) 打赏

评论列表 共有 0 条评论

暂无评论

微信小程序

微信扫一扫体验

立即
投稿

微信公众账号

微信扫一扫加关注

发表
评论
返回
顶部